Полезные материалы

Автоподстановка сотрудника выполнившего предыдущее действие в обработке документа.

Бывают ситуации когда необходимо чтобы сотрудник принявший задачу к исполнению так же исполнял и последующие задачи в обработке документа. Например, при адресации через Роли, менеджер начавший работать по сделке, или в случае нашего примера Бухгалтер принявший документы в работу.


Будем делать для такой обработки документа, где «Бухгалтер» — это роль, в которую входит несколько бухгалтеров и любой из них может взять документы в работу.

Обработка документа

1. Заходим в Настройка— Все скрипты.

2. Выбираем вид скрипта— Автоподстановки для объектов.

3. Создаем новый скрипт. Указываем тип— Для документов

4. Вставляем в него код ниже.

ДействияПредмета = ДействияСервер.ТекущиеДействияПредмета(Объект.Ссылка,,ТекущаяДатаСеанса(),);
ТзДействия = ДействияПредмета.Выгрузить();
НайденнаяСтрока = ТзДействия.Найти(Справочники.ВидыДействий.НайтиПоНаименованию("Подготовить документ",Истина),"ВидДействия");
Если НайденнаяСтрока <> Неопределено Тогда

МассивДействий = Новый Массив;
МассивДействий.Добавить(НайденнаяСтрока.Действие);

ЗадачиПоДействию = РаботаСПроцессамиПоДействиям.ЗадачиПроцессовПоУчастникамДействий(МассивДействий);
Для Каждого ЭлементДействия ИЗ ЗадачиПоДействию Цикл

Для Каждого ЭлементЗадачи из ЭлементДействия.Значение Цикл;

ЗадачаДействия = ЭлементЗадачи.Значение;
Прервать;

КонецЦикла;
Прервать;

КонецЦикла;

Результат = ЗадачаДействия.Исполнитель;

КонецЕсли;

В третьей строчке 
НайденнаяСтрока = ТзДействия.Найти(Справочники.ВидыДействий.НайтиПоНаименованию("Подготовить документ",Истина),"ВидДействия"); 
меняем "Подготовить документ" на Ваше наименование действия.

5. Открываем Правило обработки из Вида документа.

6. Выбираем нашу автоподстановку для дейтвия "Зарегистрировать и подписать у Руководителя", которая назначит задачу на сотрудника который выполнил действие "Подготовить документ"

Все. Можем пользоваться.
Made on
Tilda